Hello coders, In this post, you will learn how to solve itertools.combinations_with_replacement() in python Hacker Rank Solution. This problem is a part of the Python Hacker Rank series.

itertools.combinations_with_replacement() in python Hacker Rank Solution
problem
itertools.combinations_with_replacement(iterable, r)
This tool returns r length subsequences of elements from the input iterable allowing individual elements to be repeated more than once.
Combinations are emitted in lexicographic sorted order. So, if the input iterable is sorted, the combination tuples will be produced in sorted order.
Sample Code :
>>> from itertools import combinations_with_replacement >>> >>> print list(combinations_with_replacement('12345',2)) [('1', '1'), ('1', '2'), ('1', '3'), ('1', '4'), ('1', '5'), ('2', '2'), ('2', '3'), ('2', '4'), ('2', '5'), ('3', '3'), ('3', '4'), ('3', '5'), ('4', '4'), ('4', '5'), ('5', '5')] >>> >>> A = [1,1,3,3,3] >>> print list(combinations(A,2)) [(1, 1), (1, 3), (1, 3), (1, 3), (1, 3), (1, 3), (1, 3), (3, 3), (3, 3), (3, 3)]
Task :
You are given a string S.
Your task is to print all possible size k replacement combinations of the string in lexicographic sorted order.
Input Format :
A single line containing the string S and integer value k separated by a space.
Constraints :
- 0 < k <= len(s)
- The string contains only UPPERCASE characters.
Output Format :
Print the combinations with their replacements of string S on separate lines.
Sample Input :
HACK 2
Sample Output :
AA AC AH AK CC CH CK HH HK KK
itertools.combinations_with_replacement() in python Hacker Rank Solution
# itertools.combinations_with_replacement() in python - Hacker Rank Solution # Python 3 # Enter your code here. Read input from STDIN. Print output to STDOUT # itertools.combinations_with_replacement() in python - Hacker Rank Solution START from itertools import combinations_with_replacement io = input().split(); char = sorted(io[0]); N = int(io[1]); for i in combinations_with_replacement(char,N): print(''.join(i));
Disclaimer: The above Problem (itertools.combinations_with_replacement() in python) is generated by Hackerrank but the Solution is Provided by Chase2Learn. This tutorial is only for Educational and Learning purposes. Authority if any of the queries regarding this post or website fill the following contact form thank you.