Java Arraylist Hacker Rank Solution

Hello coders, In this post, you will learn how to solve Java Arraylist Hacker Rank Solution. This problem is a part of the Java programming series. 

One more thing to add, don’t straight away look for the solutions, first try to solve the problems by yourself. If you find any difficulty after trying several times, then look for the solutions.

Java Arraylist Hacker Rank Solution
Java Arraylist Hacker Rank Solution

Java Arraylist Hacker Rank Solution

Problem

Sometimes it’s better to use dynamic size arrays. Java’s Arraylist can provide you this feature. Try to solve this problem using Arraylist.

You are given  lines. In each line there are zero or more integers. You need to answer a few queries where you need to tell the number located in  position of  line.

Take your input from System.in.

Input Format
The first line has an integer . In each of the next  lines there will be an integer  denoting number of integers on that line and then there will be  space-separated integers. In the next line there will be an integer  denoting number of queries. Each query will consist of two integers  and .

Constraints

Each number will fit in signed integer.
Total number of integers in  lines will not cross .

Output Format
In each line, output the number located in  position of  line. If there is no such position, just print “ERROR!”

Sample Input

5
5 41 77 74 22 44
1 12
4 37 34 36 52
3 20 22 33
5
1 3
3 4
3 1
4 3
5 5

Sample Output

74
52
37
ERROR!
ERROR!

Explanation

The diagram below explains the queries:

Java Arraylist Hacker Rank Solution

Java Arraylist Hacker Rank Solution

import java.util.ArrayList;
import java.util.List;
import java.util.Scanner;
public class Solution {
	public static void main(String[] args) {
		Scanner in = new Scanner(System.in);
		List<List<Integer>> lines = new ArrayList<List<Integer>>();
		int n = in.nextInt();
		for (int i = 0; i < n; i++) {
			List<Integer> line = new ArrayList<Integer>();
			int d = in.nextInt();
			for (int j = 0; j < d; j++) {
				line.add(in.nextInt());
			}
			lines.add(line);
		}
		int q = in.nextInt();
		for (int i = 0; i < q; i++) {
			int x = in.nextInt();
			int y = in.nextInt();
			if (y > lines.get(x - 1).size()) {
				System.out.println("ERROR!");
			} else {
				System.out.println(lines.get(x - 1).get(y - 1));
			}
		}
		in.close();
	}
}

Disclaimer: The above Problem (Java Arraylist) is generated by Hackerrank but the Solution is Provided by Chase2Learn. This tutorial is only for Educational and Learning purposes. Authority if any of the queries regarding this post or website fill the following contact form thank you.

Sharing Is Caring

Leave a Comment