Hello coders, In this post, you will learn how to solve the Lists in Python Hacker Rank Solution. This problem is a part of the Python Hacker Rank series.

Lists in Python Hacker Rank Solution
problem
Consider a list (list = []
). You can perform the following commands:
insert i e
: Insert integer at position .print
: Print the list.remove e
: Delete the first occurrence of integer .append e
: Insert integer at the end of the list.sort
: Sort the list.pop
: Pop the last element from the list.reverse
: Reverse the list.
Initialize your list and read in the value of followed by lines of commands where each command will be of the types listed above. Iterate through each command in order and perform the corresponding operation on your list.
Example
- : Append to the list, .
- : Append to the list, .
- : Insert at index , .
- : Print the array.
Output:
[1, 3, 2]
Input Format
The first line contains an integer, n, denoting the number of commands.
Each line i of the n subsequent lines contains one of the commands described above
Constraints
- The elements added to the list must be integers.
Output Format
For each command of type print
, print the list on a new line.
Sample Input 0
12 insert 0 5 insert 1 10 insert 0 6 print remove 6 append 9 append 1 sort print pop reverse print
Sample Output 0
[6, 5, 10] [1, 5, 9, 10] [9, 5, 1]
Lists in Python Hacker Rank Solution
if __name__ == '__main__': N = int(input()) # Lists in Python - Hacker Rank Solution START Output = []; for i in range(0,N): ip = input().split(); if ip[0] == "print": print(Output) elif ip[0] == "insert": Output.insert(int(ip[1]),int(ip[2])) elif ip[0] == "remove": Output.remove(int(ip[1])) elif ip[0] == "pop": Output.pop(); elif ip[0] == "append": Output.append(int(ip[1])) elif ip[0] == "sort": Output.sort(); else: Output.reverse();
Disclaimer: The above Problem (Lists in Python) is generated by Hackerrank but the Solution is Provided by Chase2Learn. This tutorial is only for Educational and Learning purposes. Authority if any of the queries regarding this post or website fill the following contact form thank you.